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U-Server Overview
U-Server Overview

1.1

Server Provisioning
Prior to installation of Utelogy software, the servers should be provisioned with the following:
VMs installed and configured, if utilizing VM.
Operating System Installed.
Network configuration with address or name.
Create an administrator level account (can use “administrator”) to allow software
installation.
Browser access to the internet confirmed – to download software/drivers/updates,
etc.
.NET 3.5 sp 1 or better installed.
If soft firewall is enabled, open up ports TCP 12600-12603 inbound and outbound.
VPN access or other (e.g. Log-Me In) setup, if remote Utelogy support is desired for
installation.

1.1.1

System Requirements
Before you begin installation of the Utelogy Software, please verify that your computer meets
the following minimum requirements.

Minimum Hardware
1.8 GHz (GHz) CPU or better.
Minimum 2 Gigabyte (GB) of RAM, 4GB preferred.
20 Gigabyte of disk storage.

Software Needed
Minimum Windows versions: Windows Server 2003 SP1 or Server 2008
.NET 3.5 SP1 or newer. If you do not have .NET 3.5 SP1 or higher, you can download
it from the Microsoft website.
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U-Server Components
U-Server is comprised of a set of system components that perform various roles within your
control and management architecture.

1.2.1

ControlServer Service
U-Server runs as a service on the computer and “hosts” one ore more CLMs. The file is
controlserver.exe and is configured in the Windows Service Manager. The CLM
(pronounced “clem”) is the heart of the Utelogy Control and Management solution and
responsible for communication with and controlling a group of equipment, such as a room.

1.2.2

Server Manager
The Server Manager is a tool used to setup the Control Server and manage the CLMs hosted
by the server. With the Server Manager tool you can:
Define server parameters
Start and Stop the Servers
Add, Modify or Remove a CLM instance from the server.
Start, Stop or Reboot a CLM.
Additional tools to help you manage the server and CLMs

1.3

Networking & Infrustructure
Because Utelogy is a platform that utilizes your IT infrastructure and network, it is important
that your own network topology, policies, security, firewalls, etc. be considered so that the full
functionality of Utelogy is maximized and fits nicely into your environment.
Typically a review session is part of the process and involves AV, IT and Utelogy personnel
so that the design approach is reviewed and understood by all. It also serves to flush out any
nuances so that there are no surprises down the road.
Below is a simple connectivity diagram that shows how all the pieces communicate.
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U-Server is central to the Utelogy platform as its responsible for control and management of
the equipment throughout your campus/organization. As such, connectivity is required
between all the components as described here:

Connectivity Requirements
Devices - U-Server needs to be able to establish a TCP/IP connection with all the
equipment and devices that it needs to control and monitor. The connection will
require the use of a TCP port as dictated by each particular make/model of
equipment. For some common examples, see Device Ports.
U-Manage - U-Server also needs connectivity to the U-Manage Portal which is
responsible -- among other functions - for collecting analytical data from U-Server.
This uses a robust Utelogy connection that requires outbound access to the internet
on port 12601.
Windows Dashboard - The windows dashboard is typically deployed in each
© 2013 Utelogy Coproration
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classroom to be controlled and provides the User Interface (UI) functionality. It must
be able to connect to U-Server using a Utelogy connection on port 12600.
Browser Dashboard - A browser dashboard is an HTML5 browser application that
needs to connect to U-Server using standard HTTP protocol on port 80.

1.3.1

Communication Protocol
Utelogy uses TCP/IPv4 to communicate over your network. Utelogy uses it’s own, robust and
secure data scheme for sending and receiving messages and information over the network.

Utelogy TCP Ports
Utelogy uses the following socket ports:
12600 - To Communicate to U-Server.
12601 - To Communicate with the U-Mange server.

1.3.2

Device Ports
Keep in mind that for network control of equipment, each manufacturer will require
communication on certain ports. The equipment to be controlled and its port requirements
should be factored into network planning. Examples are:
GlobalCache, ports 4998 – 5000.
Extron IPLink, ports 2001 – 2006 for serial control.
NEC Control, port 7142.
Telnet, port 23, most video phones and other devices use a Telnet port/protocol.
Please consult the equipment manuals for further identification of unique network
communication requirements.

1.3.3

Network Considerations
V-LAN
Utelogy recommends the use of V-LANs to isolate and separate AV control and management
© 2013 Utelogy Coproration
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traffic. Utelogy is network friendly and can be run side-by-side with your regular network
traffic, but V-LANs provide a great way to organize you address scheme and a convenient
way to manage any routing and/or firewall traversal needs your network architecture may
require.

Class C Block Allocation
At a minimum, it is recommended that you allocate and entire block(s) to equipment address
assignment. This is simply a best practice to help organize address assignment. Additionally,
Utelogy provides tools that can scan a block of addresses to identify equipment.

Firewalls & Switching
In a Utelogy deployment there are three main “zones” of where equipment may be located.
The relevance of this depends on how you may or may not isolate your server network zone
from classroom network zone from staff network zone. Depending on your network,
switching and firewall configuration, this may or may not apply, but is good to understand.
You will wan tot make sure that any firewalls and/or switching that occur between these
zones is addressed in the network planning so that the communication between all the
Utelogy components can occur.

1.3.4

Platform Support
U-Server fully supports:
Windows Server 2003 and later.
VM (Virtual Machine) environments.
x86 and 64 bit architectures.

1.4

Drivers
In order for U-Server to control and monitor your equipment and devices, it needs additional
software installed that allows it to communicate with the particular pieces of equipment you
are deploying.
This piece of software is called a Driver.
Utelogy provides all the drivers you need via the Utelogy Driver Library. In order for you to add
a piece of equipment to a room configuration (see User Guide - U-Configure), you must first
download the appropriate driver from the Utelogy Driver Library.
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Drivers are stored in the \Drivers directory.
You can see a report of installed drivers and their related information using the Driver
Manager.

1.5

Control Logic Module
The Control Logic Module (referred to as the CLM and pronounced "Clem") is the main unit of
control in Utelogy.
A CLM represents a set of related, interacting devices and equipment required to implement a
room. Whether it is a classroom, boardroom, theater or hallway, you will have one CLM for
each "room" you want to control.
A CLM can control and monitor as many devices as you need, but it will manage everything
as a single "system" or group of equipment.
In addition, CLM will have an associated User Interface tailored to the purpose and use of the
room. That UI layout can consist of multiple modes or "presets" so that a complex room can
be made simple to use by selecting the appropriate preset to start.
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U-Server Installation
To instal U-Server -- as well as other Utelogy components -- run the installation file U-

Enterprise.exe.
This will guide you through the installation process and allow you select which features you
want to install:

When installing U-Server, the Utelogy Core feature is required and the U-Control Server
should be selected. You can either install the U-Control Server or the U-Control Stand Alone,
but not both...this will cause you problems!
You will also want to install all of the Tools features as well.
Once you have installed the U-Server software on your computer, you are now ready to
Configure U-Server.

2.1

U-Server Manager
The U-Server Manager Tool is used to setup, start and manage U-Server.
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Run the U-Server Manager...

2.1.1

Setup U-Server
Select Tools > Server > Setup to get the Setup Dialog:

Server Tab
The hosts are the IP Addresses or domain names that the Server should listen on.
Leave blank to use the computer’s default IP address
Enter multiple IP addresses, separated by a comma, if your computer has more
than one IP address you want the Server to listen on.
You can also use a computer domain name in place of an IP Address.
You can also enter a password to connect to the server (Not implemented in this version).

CLM Tab

© 2013 Utelogy Coproration
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The CLM tab is for specifying configuration parameters that will apply to all CLMs managed
by U-Server. That way, if for example, you have an enterprise license key, you can specify it
here once, rather than for each CLM that is hosted by U-Server.
Note: If an individual CLM setting (see later section of this document) specifies a setting,
that individual setting will be used. These “Global Settings” only apply when then CLM does
not specifically specify its own, individual setting.
License Key - Each CLM requires a license key in order to run. Utelogy provides an
“Enterprise” license key that applies to multiple CLMS within your organization. If you
have purchase and enterprise License Key, you can enter it here and it will be used by
all the CLMs managed by this ControlServer.
GCC Host - Specifies domain name of the U-Manage Support Center used to provide
additional services such as U-Help, Asset Management, Reporting, etc. This is
always: u-manage.utelogy.com.

2.1.2

Start U-Server
Once you have entered and saved the Configuration settings, you are now ready to start UServer.
Select Tools > Server > Run from the menu:
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Select Start to Start the Service.
You can also Stop the server by using the Stop button.

2.1.3

Connect to U-Server
Once U-Server is running, you are now ready to connect to it in order to provision CLMs.
Using the U-Server Manager Select File > Connect to get the Connection
Dialog:

Enter the host name that U-Server is listening on. This is the setting that you configured in
the U-Server Setup Section.
Once you connect, you will see a list of all the CLMs presently being hosted by U-Server. If
you haven’t added any CLMs yet, this list will be empty.
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You are now ready to begin provisioning CLMs.
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Provisioning CLMs
Once U-Server is running, you are now ready to provision your CLMs.
You do this using the U-Server Manager
A CLM (Control Logic Module) is the logical unit that runs a group of equipment as a system,
such as a classroom, conferrence room or theater. So for each room, you will need to
provision a CLM.
A CLM has a name that is unique throughout your enterprise, organization or campus.
Typically it is given the name of the building and/or room. For example:
B4-100
U-Server allows an unlimited number of CLMs to be provisioned on a single server, provided
you have a license sufficient for the number of CLMs you want to provision.
You Add a new CLM, Clone an existing CLM, or Remove a CLM.

A fully provisioned U-Server

3.1

Adding a New CLM
From the Menu, select Edit > Add CLM.
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CLM
Name - Each CLM must have a unique name within your enterprise. This is usually
the room name or other designation that identifies what the CLM is controlling.
Password - You may also specify a password that will be required when connecting
to the CLM to either perform control or configuration operations.
Note:

Once you add the CLM, you cannot change the CLM name, so be sure to
make sure it’s correct before you press OK.

License Key
Key - You do not need to enter a license key here as you have already specified your
license key when you Setup U-Server.
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U-Manage
Host - You do not need to set this up as you have already specified the host when
you Setup U-Server.

3.2

Clone an Existing CLM
You may create a copy of an existing CLM and give it a new name.
To clone a CLM, highlight the CLM you want to clone and then from the menu, select Edit

> Clone CLM
Enter in the information for the new CLM, just as if you were Adding a New CLM.
When you clone a CLM, the new cloned CLM the entire model (e.g. the Configuration) of the
CLM will also be cloned.
The Clone feature is a very useful feature when you need to setup a new room that is similar
to an existing room. Simply clone the existing room and then make the necessary
configuration changes in the new room.
Note:

3.3

The new, Cloned CLM will be in Standby mode. This is because you do not
want the cloned CLM to start running and connect to the devices that the
original CLM is controlling. You should first edit the new CLM configuration
and then move the CLM from Standby to Running mode (see subsequent
section of this document).

Remove an Existing CLM
To remove a CLM from the server, highlight the CLM and from the menu select CLM >

Remove
This will delete all information associated with the CLM, including its settings and model.
If you do not want to permanently remove the CLM, you can change the execution mode and
put it in Standby to stop it from running.

3.4

Modify a CLM
To change the settings for a particular CLM, highlight the CLM and from the menu select CLM

> Modify

© 2013 Utelogy Coproration
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CLM Execution
Once a CLM has been provisioned, it is now alive and "executing."
There a few things you can do to an executing CLM to maintain and manage your
deployment:
Change the Execution Mode
Adjust Tuning Parameters

4.1

Execution Mode
A CLM has two execution modes:
Standby. In Standby mode the CLM is not actively controlling and polling devices and
is essentially offline. However, U-Configure may connect to CLM to make
configuration changes.
Run. In Run mode, the CLM is fully activated and connected to, controlling and polling
devices.
To change the Execution Mode of a CLM, highlight the CLM and then select the new mode
from the Exec menu.

To change the execution mode, select the CLM and select an option from the Exec menu:
Run. Place the CLM in Run mode. In run mode, the CLM is in full operation and is
connected to all the devices (as per the configuration).
Standby. Place the CLM in Standby mode. In stand-by mode, the CLM may be
configured, but is not actively controlling the devices. It may also not be used by any
© 2013 Utelogy Coproration
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Dashboard and the server will report that the CLM is "unavailable".
Reboot. This will fully re-cycle the CLM and should only be used if you are
experiencing issues with a single CLM.

4.2

Tuning Settings
The tuning settings apply to all CLMs running on the U-Server. These settings may be
changed at anytime while the server is running, and may be done so without affecting the
operation of the system. The tuning settings are used for system optimization withing your
particular environment.
You can access the Tuning Settings under the Tools > CLM > Tuning Settings
menu.

See Device Tuning Settings, Logging Tuning Settings.
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Device Tuning Settings
These settings pertain to the connections that U-Server makes to the equipment it is
controlling. Optimizing for performance can allow you to match U-Server to your particular
networking environment through the following settings:

Network Timeout
The number of seconds to wait for a response over the network. If the timeout is reached,
Utelogy assumes that the device that is being communicated with cannot respond and UServer will not wait any longer. For slower networks such as wide-area topologies (WAN),
you may want to extend this longer.
You can put any number of seconds here, including decimal points. E.g. 2.5 = two and a half
seconds. U-Server defaults to 2 seconds.

Recycle Time
This is the number of seconds to keep a connection open, after which it is closed until the
connection is needed again. This is most useful in networks with firewalls and routers that
may have a "dislike" for managing connections with long sessions. In these cases, the
network equipment tends to remove old connections from its session table, potentially
causing connection anomalies.
By setting the Recycle Time to some positive number, this tells U-Server to close and reopen the connection, thereby keeping is "fresh."
You can put any number of seconds here. A typical configuration might be 300 seconds = 5
minutes. Be default, the settings is 0 seconds, which means that connections are never
recycled.

End Data Wait
Depending on the network based hardware you have deployed, some devices may send a
network packet of data to U-Server before the entire message is available. What this means
is that a device response of 20 bytes may arrive as two smaller responses of say 12 and 8
bytes. You can witness this in the Control Tool application where you will see a single logical
response showing up as multiple device responses.
The End Data Wait setting tells U-Server to wait a certain amount of time for additional
message(s) before processing the response. By default this value is set to .002 seconds = 2
milliseconds.

© 2013 Utelogy Coproration
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Watch Dog Timeout
The watch dog timeout will terminate a connection if it doesn't receive any data within the
specified time period after sending data. What this condition usually means is that either 1)
the device does not send responses and the connection can be closed, or 2) the network
communication to the device is in an abnormal state.
In either case, the watch dog timer will actively close the connection. The next time the
connection is needed, it will be opened.

4.2.2

Logging Tuning Settings
Sometimes it is useful to understand what's happening under-the-hood, particular when it
comes to network communication. By enabling logs, Utelogy will create text files that contain
diagnostic information that you can read to see what is happening inside U-Server.
When enabled, these logs will be written in the Utelogy installation directory under the
\Logs folder.
Sockets - Sockets are the network connections between U-Server and the devices
it's controlling. This log is useful to understand network communication and
performance of the system. Each socket connection will be logged to its own file
named with the following format: Address-Port.txt
EndPoints - And EndPoint is a Utelogy connection that all the components use to
communicate (Dashboard, Tools, U-Manage, etc). Sometimes it is useful to have
detailed information about EndPoint communication.
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Tools
There are some additional tools to make the setup and management of U-Server easier:
Driver Manager - Allows you to see the installed drivers and versions and -- in a future
release -- to automatically update and install new drivers.
Client Router Map - Maps a dashboard to a particular CLM based on the machine
name of the dashboard. This allows you to have a standard "image" on all your client
machines and let U-Server control what machine controls which room.
NetScan - Scans the network for IP based devices.

5.1

Driver Manager
The Driver Manager is a tool that tells you what drivers you have installed/missing and what
CLMs are using them. To access the Driver Manager, you must be connected to the UServer and then from the menu select Tools > Driver Manager

Exam ple Driver Manager

The Driver Manager shows:
All the installed driver file
The Driver Version umber
The Driver Date
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How many times it is being used (e.g. referenced in a CLM model)
Which CLMs are using the driver.
When you add or update drivers, you can click the Refresh button to update the information
being displayed.
Note:

5.2

In a future release, the Driver Manager will allows you to selectively and
automatically update and install new drivers.

Client Router Map
The Client Router Map allows you to control, from U-Server, what room a Dashboard controls
when it connects to U-Server.
The Client Router Map is useful when you have many rooms to support and are currently
providing "imaging" or "ghosting" to deploy and update your computing infrastructure. The
only the only unique configuration on these computers that is required by the Utelogy
Dashboard is the room to connect to. By moving this information the the U-Server Client
Router Map, you can now put the Utelogy dashboard onto your computer images as a
standard install.
To access the Client Router Map you must be connected to U-Server and then from the
menu select Tools > Client Router Map:
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The Client Router Map shows a list of each CLM that has been provisioned. In the edit box
next to the CLM name, enter the name of the machine that you want to automatically connect
to that CLM:
Upper/Lower case does not matter.
You can put multiple machine names in the list. Just separate them with a comma (,)
You do not need to use the Client Router Map for every room.
In order for a dashboard to use the Client Router List, leave the CLM name blank.

5.3

NetScan
The NetScan tool is an easy way to discover IP enabled devices on the network.
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Net Scan will look at all IP addresses in a specified Class C subnet. This is the set of IP
addresses, such as:
172.26.48.nnn, where nnn is 1- 255.
Typically in a deployment, all of your devices will be isolated to a single subnet (or several
subnets for a larger deployment. Net Scan searches by using the following protocols/tests:
Ping. A ping request is made to the IP and the response is indicated.
HTTP. An HTTP request (e.g. Web Browser) request is made to the IP address and
the title of the home webpage is indicated if a response was received.
Host. The DNS name for the IP address is displayed if it can be resolved.
Note: Only IP addresses that respond to the Ping or HTTP request will show in the resulting
list.
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Endnotes 2... (after index)
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